Thanks to Wayne Shulz at 90minds.com for this posting of which versions of the Sage MAS90, MAS200 and MAS500 products are currently supported by Sage.

Below is a form showing version 3.71 and higher (including the almost forgotten MAS200 SQL Version) and what levels or versions are still supported.  Note that Sage can discontinue support for any of these versions within 12 months notice.  To be sure, check with us before assuming this list is perfect although we try and keep it current.
Supported Versions Policy MAS90 MAS200 MAS500